English English English English English Deutsch Deutsch Deutsch Nederlands Nederlands Français Français Español

Téléchargement

Les téléchargements individualisés figurent dans la colonne de droite. Pour s'assurer d'une installation correcte, Il est recommandé de lire ce qui suit.

Licence

La licence de mise à niveau de la version 4 à la version 5 est payante. Après installation de iTrain 5.0, entrez d’abord la clé de votre licence avant d’ouvrir les fichiers utilisés par la version 4.1

Configuration requise

Il y a des pré-requis de configuration à vérifier pour faire fonctionner ce programme. Vous avez besoin au minimum d'un ordinateur avec un système d'exploitation 32 ou 64 bits comme macOS, Windows ou Linux. Vous aurez besoin d'avoir installé un Java Runtime Environnement (JRE), version 8 ou supérieur. Si possible, nous vous recommandons d'installer la version 11 ou supérieure pour prendre en charge les moniteurs UHD (4K).

Le minimum de mémoire vive nécessaire est de 1 Gb. La résolution minimale pour faire fonctionner iTrain est de 1280 x 800. Selon la taille du circuit, une résolution supérieure peut être indispensable.

Port série et USB

Certains systèmes digitaux (Marklin 6021/51 ou Intellibox IR) sont connectés à l'ordinateur par un port série. Dans ce cas vous avez besoin d'avoir un port série disponible sur votre ordinateur. Sur la plupart des PC vous pouvez utilisez le port COM, mais les ordinateurs Apple et les derniers PC portables n'ont plus de port série. Vous pouvez alors utiliser un adaptateur série-USB. Nous vous recommandons un, basé sur le chipset FTDI.

Certaines stations de commande digitale plus modernes ont déjà une interface USB. Dans la plupart des cas cette interface USB émule un port série dans le programme ce qui permet à iTrain de fonctionner comme si il y avait un port série. L'émulation de ce port série Vitual Com Port (VCP) nécessite l'installation de drivers sur votre ordinateur. Normalement les drivers Windows sont déjà fournis sur un CDRom. Mais dans beaucoup de cas, les drivers pour macOS et Linux doivent être téléchargés par Internet en fonction du chipset du fournisseur.

Selon votre système digital, deux drivers sont très populaires et permettent leur fonctionnement sur plusieurs plates formes:

Installation

La procédure d'installation diffère selon le système d'exploitation:

macOS (OS X)

Pour les systèmes d’exploitation, El Capitan (10.11), Sierra (10.12), High Sierra (10.13), Mojave (10.14) et Catalina (10.15) Java doit être installé en premier. Nous vous recommandons d'installer OpenJDK 11 avec support à long terme (LTS). Nous préférons le JRE avec le programme d'installation PKG de BellSoft, mais d'autres distributions sont également prises en charge.

Une fois Java installé, vous pouvez télécharger l'image du disque macOS et copiez l'application dans votre dossier 'Applications'.

Pour OS X 10.7 - 10.10, nous vous recommandons de mettre à niveau au moins El Capitan (10.11) si cela est possible avec votre Mac.

Vous pouvez le déplacer dans 'Dock' pour le démarrer également depuis ce dossier.

Windows

Java doit être installé en premier. Nous vous recommandons d'installer OpenJDK 11 avec support à long terme (LTS). Nous préférons le JRE avec le programme d'installation MSI de BellSoft, mais d'autres distributions sont également prises en charge.

Après avoir installé Java, vous pouvez télécharger et installer l'installeur et l'exécuter en double-cliquant. Ignorez tout avertissement avant le début du téléchargement et attendez-vous à une demande de modification de votre système. Cela est nécessaire pour installer iTrain dans le dossier 'Program files'.

Ignorez tout avertissement avant le début du téléchargement et attendez-vous à une demande de modification de votre système. Cela est nécessaire pour installer iTrain dans le dossier 'Program files'.

Linux

Java doit être installé en premier. Pour vérifier si Java a déjà été installé sur votre ordinateur, ouvrez une fenêtre terminale et tapez la commande suivante:

java -version

Si Java n'est pas installé en version 8 ou supérieure, il vous faut installer une nouvelle version. Dans ce cas utilisez le gestionnaire de paquetage de votre distribution Linux pour installer Java.

Ubuntu: sudo apt install default-jre

Si cela ne fonctionne pas sur votre distribution Linux, vous devez installer OpenJDK manuellement. Nous vous recommandons d'installer OpenJDK 11 avec support à long terme (LTS).

Après avoir installé Java, vous pouvez télécharger et installer l'installeur. Si l'installation ne peut pas être exécutée, vous pouvez le lancer depuis la ligne de commande:

java -jar iTrain_install.jar
'