English English English English English Deutsch Deutsch Deutsch Nederlands Nederlands Français Français Español

Downloads

De downloads staan aan de rechterkant. Voordat deze geïnstalleerd worden is het goed om het volgende eerst even te lezen om problemen te voorkomen.

Migratie

Voor de overstap naar versie 5.0 zijn een paar handmatige stappen nodig. Zonder deze stappen zal het oude baanplan niet meer goed werken. Deze stappen zijn beschreven in de aankondigingen in het iTrain-forum, die bij elke upgrade even gelezen moeten worden.

Licentie

Versie 5 is een betaalde update. Dat betekent dat mensen die al een 4.x licentie gekocht hebben een update moeten kopen om te kunnen overstappen. Na het installeren van versie 5.0 zal eerst de licentie opnieuw moeten worden ingevoerd en daarna pas het bestand worden geopend, waarmee u in 4.1 bezig was. Oudere bestanden moeten eerst in iTrain 4.1 geopend en bewaard worden voordat ze in iTrain 5.0 geopend kunnen worden.

Systeemeisen

Er zijn een paar systeemeisen om iTrain te kunnen gebruiken. Er is in ieder geval een computer met een 32-bit of 64-bit besturingsprogramma nodig zoals macOS, Windows of Linux. Op deze computer moet een Java Runtime Environment (JRE) versie 8 of hoger aanwezig zijn. We raden echter aan om minimaal versie 11 te gebruiken voor ondersteuning van UHD-monitoren (4K).

De minimale hoeveelheid geheugen is 1 Gb RAM. Voor het scherm is minimaal een resolutie van 1280 x 800 gewenst om het schakelbord goed te kunnen lezen. Afhankelijk van de grootte van de modelbaan is een hogere resolutie aan te bevelen.

Seriële poort en USB

Sommige oudere digitale systemen (Märklin 6021/51 of Intellibox IR) worden met de computer verbonden via een seriële poort. De meeste computers hebben echter geen seriële poort meer. In dit geval moet er gebruik gemaakt worden van een USB naar serieel adapter. Wij hebben goede ervaringen op alle platformen (macOS, Windows, Linux) met adapters met een FTDI-chipset.

Modernere digitale systemen hebben al een USB-interface. In de meeste gevallen emuleert de USB-interface een seriële poort in software, zodat iTrain gewoon een extra seriële poort ziet. Voor de seriële poortemulatie of Virtuele Com Poort (VCP) moeten drivers geïnstalleerd worden op de computer. Drivers voor Windows worden standaard meegeleverd op een CD-rom, maar meestal zijn er ook drivers voor macOS en Linux beschikbaar via het internet bij de leverancier van de chipset.

Afhankelijk van het digitale systeem worden twee drivers veel gebruikt en zijn beschikbaar voor meerdere besturingssystemen:

Installeer bij voorkeur deze drivers van internet in plaats van degene die mee geleverd worden door de fabrikant, want deze zijn in veel gevallen ouder en bevatten nog onvolkomenheden zeker voor 64-bits systemen.

Installatie

De installatie is per besturingssysteem verschillend:

macOS (OS X)

Bij El Capitan (10.11), Sierra (10.12), High Sierra (10.13), Mojave (10.14) en Catalina (10.15) moet eerst Java geïnstalleerd worden. Wij raden aan om OpenJDK 11 met Long Term Support (LTS) te installeren. Daarbij geven wij de voorkeur aan een JRE met PKG-installer van BellSoft, maar andere distributies worden ook ondersteund.

Als iTrain geïnstalleerd is dan moet het macOS disk image gedownload en geopend worden. Daarna moet het programma iTrain naar de map "Programma's" worden gekopieerd.

Als u nog OS X 10.7 - 10.10 gebruikt raden we aan om te upgraden naar El Capitan (10.11) indien dit mogelijk is met uw Mac.

Het is handig om iTrain ook naar de 'Dock' te slepen om het snel te kunnen starten.

Windows

Eerst moet Java geïnstalleerd worden. Wij raden aan om OpenJDK 11 met Long Term Support (LTS) te installeren. Daarbij geven wij de voorkeur aan een JRE met MSI-installer van BellSoft, maar andere distributies worden ook ondersteund.

Na het installeren van Java kan het installatieprogramma gedownload en geïnstalleerd worden. Voer het daarna uit door erop te dubbelklikken. Negeer daarbij een eventuele waarschuwing voordat het downloaden begint en verwacht een verzoek om veranderingen aan uw systeem uit te voeren, waarbij de OpenJDK-leverancier wordt genoemd. Dit laatste is nodig om iTrain in de map 'Program files' te kunnen installeren.

Linux

Java moet eerst geïnstalleerd zijn. Om dit te controleren moet er in de Terminal het volgende ingetypt worden en met de ENTER-toets worden afgesloten:

java -version

Als er geen Java 8 of hoger beschikbaar is, installeer deze dan. Ga naar de package manager van de Linux-distributie om een Java Runtime Environment (JRE) te downloaden.

Ubuntu: sudo apt install default-jre

Als dit niet werkt met uw distributie dan moet OpenJDK handmatig geïnstalleerd worden. Wij raden aan om OpenJDK 11 met Long Term Support (LTS) te installeren.

Na het installeren van Java kan het installatieprogramma gedownload en geïnstalleerd worden. Als de installatie niet uitvoerbaar is dan is het altijd mogelijk om deze in de Terminal te starten met:

java -jar iTrain_install.jar